Searching \ for '[PIC]: PicKit2, MPLAB and OLIMEX MAXI WEB(18f97j60' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: massmind.org/techref/microchip/languages.htm?key=mplab
Search entire site for: 'PicKit2, MPLAB and OLIMEX MAXI WEB(18f97j60'.

Exact match. Not showing close matches.
PICList Thread
'[PIC]: PicKit2, MPLAB and OLIMEX MAXI WEB(18f97j60'
2009\07\03@072241 by Justin Richards

face picon face
Hi Folks,

I have successfully built my C code for the target OLIMEX_MAXI_WEB but I am
having problems with programming and debugging via the MPLABv8.20 IDE.

I understand that some devices are not supported directly by the IDE using
PicKit2 but I have checked the list and it indicated that the 18F97J60 is
supported directly for both debugging and programing.

I can successfully program the target using the PicKit2 software but fails
when I try it from the IDE.

The error I get is PK2Error0027 (verify failed).  I can confirm that the
device gets erased and I can read from the target (once it has been
programmed via PickKit2 software) via the IDE I just can not program it.

I have another device (pickit2 express debug board) that I can program and
debug successfully but this uses PicKit2 to provide target power supply
requirements whereas the OLIMEX_MAXI_WEB has its own power supply.

Usually I would just keep trying but I have tried 10 times to program, so I
figure that is 10 erases and the Manual for 18f97j60 indicates that it is
only good for approx 100.  Therefore I have reduced its usefulness
significantly and haven't really achieved anything.

I really need to get into debug mode and to do this I need to be able to
program from the IDE (I did try to program from PicKit2 software first and
then enter debug mode but this also fails).

If anyone has had success ICSP programming 18f97j60 or better yet the
OLIMEX_MAXI_WEB with PicKit2 please indicate so.

If I know it can be done I will be more inclined to try at the cost of using
up my 100 program cycles.

Cheers Justin


'[PIC]: PicKit2, MPLAB and OLIMEX MAXI WEB(18f97j60'
2009\08\09@121520 by Justin Richards
face picon face
For completeness incase others experience this problem.

I upgraded to 8.33 and certain that this solved the problem.

In debug settings I have the following options checked.

Use Prog Exec if available
and
Set VDD voltage to 3.5V

I also ignore the "Can not enter debug" message which i believe just
indicates that the option "Run after successful build" option is not set.

2009/7/3 Justin Richards <spam_OUTjustin.richardsTakeThisOuTspamgmail.com>

{Quote hidden}

More... (looser matching)
- Last day of these posts
- In 2009 , 2010 only
- Today
- New search...